Форум по микроконтроллерам: Упрощённый вариант - Форум по микроконтроллерам

Перейти к содержимому

  • 14 Страниц +
  • « Первая
  • 10
  • 11
  • 12
  • 13
  • 14
  • Вы не можете создать новую тему
  • Вы не можете ответить в тему

Упрощённый вариант На PIC16F84

#221 Пользователь офлайн   Alexprozorov 

  • Новичок
  • Pip
  • Группа: Пользователи
  • Сообщений: 41
  • Регистрация: 13 Июль 13

Отправлено 15 Март 2015 - 07:46

Просмотр сообщенияMatsik91 (14 Март 2015 - 21:48) писал:

А что именно Вы отредактировали в прошивке? Почему-то при включении заслонка несколько раз ездит в крайние положения, потом полностью открывается и все :D


ну да, че-то тормознул :-)) Прошу прощения
я добавил пару комманд сброса watchdog таймера
и в одном месте не учел goto с относительным шагом

поменял

Прикрепленные файлы

  • Прикрепленный файл  21093_m.asm (56,21К)
    Количество загрузок:: 112

0

#222 Пользователь офлайн   Mysterious93 

  • Знаток
  • PipPip
  • Группа: Пользователи
  • Сообщений: 66
  • Регистрация: 24 Сентябрь 14

Отправлено 15 Март 2015 - 14:54

все тестирую прошивку . после прогрева сбрасывается не всегда . грешил на свечные провода .сегодня заменил .посмотрю как будет дальше работать .

ну а в общем приходится в ручную выставлять обороты кнопками .
0

#223 Пользователь офлайн   Alexprozorov 

  • Новичок
  • Pip
  • Группа: Пользователи
  • Сообщений: 41
  • Регистрация: 13 Июль 13

Отправлено 15 Март 2015 - 21:26

Просмотр сообщенияMysterious93 (15 Март 2015 - 14:54) писал:

ну а в общем приходится в ручную выставлять обороты кнопками .


Потому, что автоматически не выставляются или просто неоптимальные настройки?
0

#224 Пользователь офлайн   Mysterious93 

  • Знаток
  • PipPip
  • Группа: Пользователи
  • Сообщений: 66
  • Регистрация: 24 Сентябрь 14

Отправлено 15 Март 2015 - 23:12

Просмотр сообщенияAlexprozorov (15 Март 2015 - 21:26) писал:

Просмотр сообщенияMysterious93 (15 Март 2015 - 14:54) писал:

ну а в общем приходится в ручную выставлять обороты кнопками .


Потому, что автоматически не выставляются или просто неоптимальные настройки?


такое чувство что не захватываются обороты . и сегодня опять начинала схема в движении закрывать заслонку и температура была около 70-80 градусов
0

#225 Пользователь офлайн   Alexprozorov 

  • Новичок
  • Pip
  • Группа: Пользователи
  • Сообщений: 41
  • Регистрация: 13 Июль 13

Отправлено 16 Март 2015 - 06:55

Просмотр сообщенияMysterious93 (15 Март 2015 - 23:12) писал:

такое чувство что не захватываются обороты . и сегодня опять начинала схема в движении закрывать заслонку и температура была около 70-80 градусов


Очень странно. Я езжу каждый день и подобного не замечаю. Откуда выберете сигнал для подсчета оборотов? У меня береться прямо с катушки зажигания. БСЗ. Немного пришлось подобрать значения сопротивлений и емкость крнденсаторов. До этого обороты определяла криво и вела себя неправильно. Чтобы в движении заслонку закрывала, такого не помню. Было правда больше года назад. Если надо могу посмотреть значения сопротивлений и емкостей на своей схеме. Программно заложено так, что заслонка полностью открывается при значении температуры TZP_5 и потом не трогает, только вручную.
Вот пока писал вспомнил - я на входы с кнопок управления вешал конденсаторы 0,1 мкФ и подтягивал вход на 5В через сопротивления 2.2-4.7 кОм. Без этого самопроизвольно как-будто нажимались кнопки, но это были единичные срабатывания. 5-10 раз.
Еще как вариант попробуйте прошивку Blad-58
0

#226 Пользователь офлайн   Matsik91 

  • Новичок
  • Pip
  • Группа: Пользователи
  • Сообщений: 33
  • Регистрация: 03 Декабрь 14

Отправлено 16 Март 2015 - 13:01

Просмотр сообщенияAlexprozorov (15 Март 2015 - 07:46) писал:

ну да, че-то тормознул :-)) Прошу прощения
я добавил пару комманд сброса watchdog таймера
и в одном месте не учел goto с относительным шагом
поменял

К сожалению не помогло, стало только хуже... Теперь постоянно сбрасывается, буквально после двух-трех шагов подстройки...
0

#227 Пользователь офлайн   Alexprozorov 

  • Новичок
  • Pip
  • Группа: Пользователи
  • Сообщений: 41
  • Регистрация: 13 Июль 13

Отправлено 16 Март 2015 - 13:40

Просмотр сообщенияMatsik91 (16 Март 2015 - 13:01) писал:

К сожалению не помогло, стало только хуже... Теперь постоянно сбрасывается, буквально после двух-трех шагов подстройки...


А точно прям сбрасывается? Можете поподробнее описать как себя ведет? прямо самого начала, с включения зажигания.
И еще вопрос, на исходном варианте Blad-58 без Ваших правок точно также все?
-1

#228 Пользователь офлайн   Alexprozorov 

  • Новичок
  • Pip
  • Группа: Пользователи
  • Сообщений: 41
  • Регистрация: 13 Июль 13

Отправлено 16 Март 2015 - 13:41

Просмотр сообщенияMatsik91 (16 Март 2015 - 13:01) писал:

К сожалению не помогло, стало только хуже... Теперь постоянно сбрасывается, буквально после двух-трех шагов подстройки...


А точно прям сбрасывается? Можете поподробнее описать как себя ведет? прямо самого начала, с включения зажигания.
И еще вопрос, на исходном варианте Blad-58 без Ваших правок точно также все?
0

#229 Пользователь офлайн   Blad-58 

  • Знаток
  • PipPip
  • Группа: Пользователи
  • Сообщений: 55
  • Регистрация: 24 Май 13

Отправлено 16 Март 2015 - 15:57

Matsik91 Попробуйте этот вариант прошивки. Сам в железе не проверял машина в ремонте.

С уважением !!!

Прикрепленный файл  21093-проба.HEX (4,78К)
Количество загрузок:: 83
0

#230 Пользователь офлайн   Mysterious93 

  • Знаток
  • PipPip
  • Группа: Пользователи
  • Сообщений: 66
  • Регистрация: 24 Сентябрь 14

Отправлено 16 Март 2015 - 20:28

попробовал сегодня прошивку из поста 218 21093.asm и в процессе начала прогрева заслонка около 5 раз открывалась и машина глохла ...как ток прогревалась немного глюк проподал .собственно как и описанно в том посте ,но чуть уточню . в моем случае еще и после полного прогрева около 85 градусов схема снова запускалась и полностью на ходу закрывала заслонку . заметил еще по магнитоле что когда включал радио ,то идут небольшие слабо уловимые помехи и это несмотря на то что заменены свечные провода на новые . машина с бесконтактным зажиганием с коммутатором 2108.

подскажите мож какой фильтр от этих помех ...
0

#231 Пользователь офлайн   Blad-58 

  • Знаток
  • PipPip
  • Группа: Пользователи
  • Сообщений: 55
  • Регистрация: 24 Май 13

Отправлено 16 Март 2015 - 21:11

Mysterious93 Прежде всего плату делал с двухсторонним покрытием, на одной стороне печать, другая как экран. После выходного разьема все провода в экране(кроме питания и редуктора).Сигнал подавал не с катушки, а с ДХ. Закрытие заслонки на ходу было когда датчик был прилеплен на один из шлангов. Как потом выяснилось из за набегающего потока воздуха. Судя по Вашим описаниям у вас лезет ВЧ составляющая. Если вы делали плату предложенную мной, то после диода +12v стоит поставить дросель на 100мкГн. Ну где то так для начала, лично у меня подобных глюков нет.


С УВАЖЕНИЕМ !!!
0

#232 Пользователь офлайн   Mysterious93 

  • Знаток
  • PipPip
  • Группа: Пользователи
  • Сообщений: 66
  • Регистрация: 24 Сентябрь 14

Отправлено 16 Март 2015 - 21:24

ну у меня так плата ....макетка ,а вот датчик примотан на шланг - переделаю .

в ближайшие дни куплю дроссель и попробую

а пока буду ездить с этой прошивкой .больше всего нравится

Прикрепленные файлы


0

#233 Пользователь офлайн   Matsik91 

  • Новичок
  • Pip
  • Группа: Пользователи
  • Сообщений: 33
  • Регистрация: 03 Декабрь 14

Отправлено 16 Март 2015 - 23:05

В общем я пробовал различные прошивки и пришел к выводу, что эта мне больше всех нравится. Только в ней может быть в начале пару сбросов, а потом нормальная работа. И кстати заметил, что при включении вентилятора печки или дальнего света загорается светодиод открытия заслонки и пищит, мол заслонка открыта. Кто-нибудь знает от чего это может быть?

Прикрепленные файлы

  • Прикрепленный файл  VAZMOY1.hex (4,44К)
    Количество загрузок:: 84

0

#234 Пользователь офлайн   Alexprozorov 

  • Новичок
  • Pip
  • Группа: Пользователи
  • Сообщений: 41
  • Регистрация: 13 Июль 13

Отправлено 17 Март 2015 - 13:02

Просмотр сообщенияMatsik91 (16 Март 2015 - 23:05) писал:

В общем я пробовал различные прошивки и пришел к выводу, что эта мне больше всех нравится. Только в ней может быть в начале пару сбросов, а потом нормальная работа. И кстати заметил, что при включении вентилятора печки или дальнего света загорается светодиод открытия заслонки и пищит, мол заслонка открыта. Кто-нибудь знает от чего это может быть?


Вы питание на схему с какого места берете?
0

#235 Пользователь офлайн   Matsik91 

  • Новичок
  • Pip
  • Группа: Пользователи
  • Сообщений: 33
  • Регистрация: 03 Декабрь 14

Отправлено 17 Март 2015 - 13:40

С замка зажигания, но даже когда с АКБ брал, было также
0

#236 Пользователь офлайн   Alexprozorov 

  • Новичок
  • Pip
  • Группа: Пользователи
  • Сообщений: 41
  • Регистрация: 13 Июль 13

Отправлено 17 Март 2015 - 14:22

Просмотр сообщенияMatsik91 (17 Март 2015 - 13:40) писал:

С замка зажигания, но даже когда с АКБ брал, было также


масса?
0

#237 Пользователь офлайн   Matsik91 

  • Новичок
  • Pip
  • Группа: Пользователи
  • Сообщений: 33
  • Регистрация: 03 Декабрь 14

Отправлено 17 Март 2015 - 18:06

И масса и плюс, может зашунтировать питание контроллера конденсатором на 0,1 мкФ?
0

#238 Пользователь офлайн   Alexprozorov 

  • Новичок
  • Pip
  • Группа: Пользователи
  • Сообщений: 41
  • Регистрация: 13 Июль 13

Отправлено 17 Март 2015 - 19:29

Просмотр сообщенияMatsik91 (17 Март 2015 - 18:06) писал:

И масса и плюс, может зашунтировать питание контроллера конденсатором на 0,1 мкФ?


Попробуйте.
А стабилизатор на 5 вольт какой? и емкости конденсаторов в цепи питания?
0

#239 Пользователь офлайн   Matsik91 

  • Новичок
  • Pip
  • Группа: Пользователи
  • Сообщений: 33
  • Регистрация: 03 Декабрь 14

Отправлено 17 Март 2015 - 21:50

Просмотр сообщенияAlexprozorov (17 Март 2015 - 19:29) писал:


Попробуйте.
А стабилизатор на 5 вольт какой? и емкости конденсаторов в цепи питания?

Стабилизатор LM7805, емкости по 470 мкФ... В общем я много чего перепробовал и решил оставить все как есть. В принципе устраивает... Просто устал уже с этим устройством возиться...
0

#240 Пользователь офлайн   SiMpS 

  • Прибывший
  • Группа: Пользователи
  • Сообщений: 2
  • Регистрация: 18 Март 15

Отправлено 18 Март 2015 - 12:49

Здраствуйте приобрел автоподсос по вашей схеме но не дали инструкий по подключению что куда, помогите разобратся есть схема но куда конкретно и что в машину подключать не понял
https://yadi.sk/d/obuD0ZYCfLANq

Сообщение отредактировал SiMpS: 18 Март 2015 - 12:52

0

Поделиться темой:


  • 14 Страниц +
  • « Первая
  • 10
  • 11
  • 12
  • 13
  • 14
  • Вы не можете создать новую тему
  • Вы не можете ответить в тему

1 человек читают эту тему
0 пользователей, 1 гостей, 0 скрытых пользователей