Форум по микроконтроллерам: Упрощённый вариант - Форум по микроконтроллерам

Перейти к содержимому

  • 14 Страниц +
  • « Первая
  • 12
  • 13
  • 14
  • Вы не можете создать новую тему
  • Вы не можете ответить в тему

Упрощённый вариант На PIC16F84

#261 Пользователь офлайн   Mysterious93 

  • Знаток
  • PipPip
  • Группа: Пользователи
  • Сообщений: 66
  • Регистрация: 24 Сентябрь 14

Отправлено 11 Апрель 2015 - 19:08

ну у меня термостат на 80 стоит . я с расчетом что на малой скорости он будет не так эффективен и как раз к 80 будет нормально .

график устраивает ,но есть вопрос : после 50 градусов не будет ли включатся ли подсос ?,а то по графику он должен поддерживать 1000 а холостой ход то меньше

кстати в скачанной прошивке не заметил изменений или они делаются не в графе "Инициализация ПЗУ" ?
0

#262 Пользователь офлайн   Alexprozorov 

  • Новичок
  • Pip
  • Группа: Пользователи
  • Сообщений: 41
  • Регистрация: 13 Июль 13

Отправлено 12 Апрель 2015 - 05:25

Просмотр сообщенияMysterious93 (11 Апрель 2015 - 19:08) писал:

ну у меня термостат на 80 стоит . я с расчетом что на малой скорости он будет не так эффективен и как раз к 80 будет нормально .

график устраивает ,но есть вопрос : после 50 градусов не будет ли включатся ли подсос ?,а то по графику он должен поддерживать 1000 а холостой ход то меньше

кстати в скачанной прошивке не заметил изменений или они делаются не в графе "Инициализация ПЗУ" ?


Про охлаждение - дело Ваше.

После Tzp_5 ( у Вас 50 гр.) заслонка полностью открывается и дальше ей можно оперировать только вручную.

Установки - часть осталась в ПЗУ а часть просто как константы. Я менял
	#DEFINE SM_PLUS			.0   смещение при полож. температурах
	#DEFINE SM_MINUS		.56  смещение при отриц. температурах
	#DEFINE STEEPNESS		.2   наклон при отриц. температурах
	#DEFINE STEEPNESS_P		.3   наклон при полож. температурах


При отрицательных температурах за начальную берется Tzp_1. От параметра SM_MINUS зависит при какой температуре обороты начнут уменьшаться. При более низких температурах обороты будут Oborot_1.
наклон зависит от STEEPNESS. При положительных все также, только используются Tzp_3, Oborot_3, SM_PLUS, STEEPNESS_P.
0

#263 Пользователь офлайн   Mysterious93 

  • Знаток
  • PipPip
  • Группа: Пользователи
  • Сообщений: 66
  • Регистрация: 24 Сентябрь 14

Отправлено 14 Апрель 2015 - 21:31

тестирую прошивку и как то оно не очень . 1) заметил ступеньку похожая как на графике и 2)внезапное закрытие заслонки которое чаще было связано с включением охлаждения (вместо ключа у меня стоит временно светодиод на порту) и самое интересное включение светодиода происходило только в один день из всех тестируемых ,хотя машина почти каждый день нагревается до включения штатных вентиляторов .

Прикрепленные изображения

  • Прикрепленное изображение: graffic_m93.jpg

Сообщение отредактировал Mysterious93: 14 Апрель 2015 - 21:53

0

#264 Пользователь офлайн   Alexprozorov 

  • Новичок
  • Pip
  • Группа: Пользователи
  • Сообщений: 41
  • Регистрация: 13 Июль 13

Отправлено 15 Апрель 2015 - 03:52

Просмотр сообщенияMysterious93 (14 Апрель 2015 - 21:31) писал:

тестирую прошивку и как то оно не очень . 1) заметил ступеньку похожая как на графике и 2)внезапное закрытие заслонки которое чаще было связано с включением охлаждения (вместо ключа у меня стоит временно светодиод на порту) и самое интересное включение светодиода происходило только в один день из всех тестируемых ,хотя машина почти каждый день нагревается до включения штатных вентиляторов .


Такая ступенька теоретически может быть только при 0 градусах. Постарюсь программно ее исключить. Какие при этом были обороты до и после ступеньки?

По 2 пункту можно поподробнее. Я правильно понял, что заслонка полностью уже открыта и при температурах близких к включению вентилятора заслонка вдруг начинала опять закрываться?
0

#265 Пользователь офлайн   Mysterious93 

  • Знаток
  • PipPip
  • Группа: Пользователи
  • Сообщений: 66
  • Регистрация: 24 Сентябрь 14

Отправлено 15 Апрель 2015 - 21:10

начиналось с 1200 и подскакивало до 1600 и потом резко на хх (около 50 градусов )

этот глюк с внезапным возрастанием оборотов был и на предыдущих прошивках .думаю связано это с помехами в бортсети авто .
а вот включение светодиода которы весит на порту вентилятора загорался только в 2 случаях когда подскакивали обороты и всё .светодиод по другим причинам не загорается хотя должен начать мерцать (шим же) с 70 градусов ?
0

#266 Пользователь офлайн   Alexprozorov 

  • Новичок
  • Pip
  • Группа: Пользователи
  • Сообщений: 41
  • Регистрация: 13 Июль 13

Отправлено 16 Апрель 2015 - 05:22

Просмотр сообщенияMysterious93 (15 Апрель 2015 - 21:10) писал:

начиналось с 1200 и подскакивало до 1600 и потом резко на хх (около 50 градусов )

этот глюк с внезапным возрастанием оборотов был и на предыдущих прошивках .думаю связано это с помехами в бортсети авто .
а вот включение светодиода которы весит на порту вентилятора загорался только в 2 случаях когда подскакивали обороты и всё .светодиод по другим причинам не загорается хотя должен начать мерцать (шим же) с 70 градусов ?


В режиме когда должен работать вентилятор должен также моргать индикатор заслонки. Не моргает?
Может попробовать датчик температурный самому подогреть зажигалкой, без фанатизма конечно.

Сообщение отредактировал Alexprozorov: 16 Апрель 2015 - 05:24

0

#267 Пользователь офлайн   Mysterious93 

  • Знаток
  • PipPip
  • Группа: Пользователи
  • Сообщений: 66
  • Регистрация: 24 Сентябрь 14

Отправлено 16 Апрель 2015 - 16:33

моргания не замечал . попробуем
0

#268 Пользователь офлайн   Mysterious93 

  • Знаток
  • PipPip
  • Группа: Пользователи
  • Сообщений: 66
  • Регистрация: 24 Сентябрь 14

Отправлено 19 Апрель 2015 - 22:59

сегодня сгорел мк .дело было так : машина простояла на ремонте(кпп скидывали) всю ночь и клемму с аккума снимали причем сам блок подсоса отключил раньше и подключил позже основного питания что собственно часто делал и такого не было ,но тут поставив блок и включив зажигание услышал беспрерывный писк зуммера .на кнопки не реагировала и чуть позже заслонка закрылась на полную и больше не какой реакции .даже дома подключив к блоку питания и больше ничего слышен один писк зуммера . вынул мк и поставив в программатор в винпике пишет неизвестное устройство и читает одни нули причем при вставленной мк тест не проходит аппаратная часть программатора(экстрапик) без него все в норме . как так не понимаю ...... завтра поеду за новым мк
0

#269 Пользователь офлайн   Mysterious93 

  • Знаток
  • PipPip
  • Группа: Пользователи
  • Сообщений: 66
  • Регистрация: 24 Сентябрь 14

Отправлено 01 Май 2015 - 15:11

все же присутстыуют глюки в виде безпричинной закрытии заслонки . что делать даж не знаю ....

Прикрепленные файлы


0

#270 Пользователь офлайн   grayling3000 

  • Новичок
  • Pip
  • Группа: Пользователи
  • Сообщений: 20
  • Регистрация: 05 Сентябрь 14

Отправлено 02 Декабрь 2017 - 21:43

здравствуйте! Я хотел уточнить-а разве диод, стоящий перед микросхемой 7805, не должен стоять к ней катодом, а к +12 анодом?
0

Поделиться темой:


  • 14 Страниц +
  • « Первая
  • 12
  • 13
  • 14
  • Вы не можете создать новую тему
  • Вы не можете ответить в тему

1 человек читают эту тему
0 пользователей, 1 гостей, 0 скрытых пользователей